ЕГЭ, вопрос 19: П. Работа с массивами

Проверяемые элементы содержания по спецификации (2019): Работа с массивами (заполнение, считывание, поиск, сортировка, массовые операции и др.)

Кодификатор 1.5.2/1.5.6/1.1.4. Уровень сложности Б, 1 балл.

Время выполнения – 5 минут.

Извините, просто пока не вижу, что надо комментировать. Все досконально разобрано еще до начала подготовки к ОГЭ.

Ключевым моментом является правильный и удобный вариант таблицы для занесения промежуточных значений.

Задания

  1. Демо 2020 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов равны 20, 19, 17, 41, 23, 12, 24, 16, 4, 13, 6, 15 соответственно, т.е. A[0] = 20, A[1] = 19 и т.д.
    Определите значение переменной s после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.
    БейсикPython
    s = 0
    n = 0
    FOR i = 0 TO 11
      IF A(i) <= A(n) THEN
        s = s + i
        t = A(i)
        A(i) = A(n)
        A(n) = t
      END IF
    NEXT i
    s = 0
    n = 0
    for i in range(12):
      if A[i] <= A[n]:
        s += i
        t = A[i]
        A[i] = A[n]
        A[n] = t
    Алгоритмический языкПаскаль
    s := 0
    n := 0
    нц для i от 0 до 11
      если A[i] <= A[n] то
        s := s + i
        t := A[i]
        A[i] := A[n]
        A[n] := t
      все
    кц
    s := 0;
    n := 0;
    for i := 0 to 11 do
      if A[i] <= A[n] then
      begin
        s := s + i;
        t := A[i];
        A[i] := A[n];
        A[n] := t
      end;
    Си++
    s = 0;
    n = 0;
    for (int i = 0; i < 12; i++)
      if (A[i] <= A[n]){
        s += i;
        t = A[i];
        A[i] = A[n];
        A[n] = t;
    }

  2. Демо 2019 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 2, 4, 3, 6, 3, 7, 8, 2, 9, 1 соответственно, т.е. A[0] = 2, A[1] = 4 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i-1) < A(i) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i-1)
        A(i-1) = t
      END IF
    NEXT i
    c = 0
    for i in range(1, 10):
      if A[i-1] < A[i]:
        c = c + 1
        A[i-1], A[i] = A[i], A[i-1]
    Алгоритмический языкПаскаль
    c := 0
      нц для i от 1 до 9
      если A[i-1] < A[i] то
        c := c + 1
        t := A[i]
        A[i] := A[i-1]
        A[i-1] := t
    все
    кц
    c := 0;
    for i := 1 to 9 do
      if A[i-1] < A[i] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i-1];
        A[i-1] := t;
      end;
    Си++
    c = 0;
    for (int i = 1; i < 10; i++)
      if (A[i-1] < A[i]){
        c++;
        t = A[i];
        A[i] = A[i-1];
      A[i-1] = t;
    }
  3. Демо 2018 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 3, 0, 4, 6, 5, 1, 8, 2, 9, 7 соответственно, т.е. A[0] = 3, A[1] = 0 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i-1) > A(i) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i-1)
        A(i-1) = t
      END IF
    NEXT i
    c = 0
    for i in range(1,10):
      if A[i-1] > A[i]:
        c = c + 1
        t = A[i]
        A[i] = A[i-1]
        A[i-1] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 9
      если A[i-1] > A[i] то
        c := c + 1
        t := A[i]
        A[i] := A[i-1]
        A[i-1] := t
      все
    кц
    c := 0;
    for i := 1 to 9 do
      if A[i-1] > A[i] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i-1];
        A[i-1] := t;
      end;
    Си++
    c = 0;
    for (int i = 1; i < 10; i++)
      if (A[i-1] > A[i]){
        c++;
        t = A[i];
        A[i] = A[i-1];
        A[i-1] = t;
      }
  4. D2018 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 3, 0, 9, 7, 8, 1, 5, 10, 2, 6, 4 соответственно, т.е. A[0] = 3, A[1] = 0 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.
    БейсикPython
    c = 0
    FOR i = 1 TO 10
      IF A(i-1) > A(i) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i-1)
        A(i-1) = t
      END IF
    NEXT i
    c = 0
    for i in range(1, 11):
      if A[i-1] > A[i]:
        c = c + 1
        t = A[i]
        A[i] = A[i-1]
        A[i-1] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 10
      если A[i-1] > A[i] то
        c := c + 1
        t := A[i]
        A[i] := A[i-1]
        A[i-1] := t
      все
    кц
    c := 0;
    for i := 1 to 10 do
      if A[i-1] > A[i] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i-1];
        A[i-1] := t;
    end;
    Си++
    c = 0;
    for (i = 1; i < 11; i++)
      if (A[i-1] > A[i])
      {
        c++;
        t = A[i];
        A[i] = A[i-1];
        A[i-1] = t;
      }
  5. R2018 (19). Ниже представлен фрагмент программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9; 5 соответственно, т.е. A[0]=5; A[1]=1 и т.д. Определите значение переменной s после выполнения следующего фрагмента программы
    БейсикPython
    s = 0
    FOR i = 0 TO 9
      s = s + A(i+1) – A(i);
    NEXT i
    s = 0
    for i in range(10):
      s = s + A[i+1] - A[i]
    Си++Паскаль
    s = 0;
    for (i=0; i<10; i++)
      s = s + A[i+1] - A[i];
    s := 0;
    for i:=0 to 9 do begin
      s := s + A[i+1] - A[i]
    end;

  6. Демо 2017 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т.е. A[0] = 1, A[1] = 2 и т.д.
    Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).
    БейсикPython
    j = 5
    WHILE A(j) < A(j-1)
      t = A(j)
      A(j) = A(j-1)
      A(j-1) = t
      j = j - 1
    WEND
    j = 5
    while A[j] < A[j-1]:
      A[j],A[j-1]=A[j-1],A[j]
      j -= 1
    Алгоритмический языкПаскаль
    j := 5
    нц пока A[j] < A[j-1]
      t := A[j]
      A[j] := A[j-1]
      A[j-1] := t
      j := j - 1
    кц
    j := 5;
    while A[j] < A[j-1] do
    begin
      t := A[j];
      A[j] := A[j-1];
      A[j-1] := t;
      j := j - 1;
    end;
    Си
    j = 5;
    while (A[j] < A[j-1])
    {
      t = A[j];
      A[j] = A[j-1];
      A[j-1] = t;
      j -= 1;
    }
  7. Демо 2016 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 7, 3, 8, 5, 0, 1, 2, 9, 6 соответственно, т.е. A[0] = 4, A[1] = 7 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i) < A(0) THEN
        c = c + 1
        t = A(i)
        A(i) = A(0)
        A(0) = t
      ENDIF
    NEXT i
    c = 0
    for i in range(1,10):
      if A[i] < A[0]:
        c = c + 1
        t = A[i]
        A[i] = A[0]
        A[0] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 9
      если A[i] < A[0] то
        c := c + 1
        t := A[i]
        A[i] := A[0]
        A[0] := t
      все
    кц
    c := 0;
    for i := 1 to 9 do
      if A[i] < A[0] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[0];
        A[0] := t;
      end;
    Си
    c = 0;
    for (i = 1;i < 10;i++)
      if (A[i] < A[0])
      {
        c++;
        t = A[i];
        A[i] = A[0];
        A[0] = t;
      }
  8. Демо 2015 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6; 9; 7; 2; 1; 5; 0; 3; 4; 8 соответственно, т.е. A[0] = 6; A[1] = 9 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i - 1) < A(i) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i - 1)
        A(i - 1) = t
      ENDIF
    NEXT i
    c = 0
    for i in range(1, 10):
      if A[i - 1] < A[i]:
        c = c + 1
        t = A[i]
        A[i] = A[i - 1]
        A[i - 1] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 9
      если A[i - 1] < A[i] то
        c := с + 1
        t := A[i]
        A[i] := A[i - 1]
        A[i - 1] := t
      все
    кц
    c := 0;
    for i := 1 to 9 do
      if A[i - 1] < A[i] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i - 1];
        A[i - 1] := t
      end;
    Си
    c = 0;
    for (i = 1; i <= 9; i++)
      if (A[i - 1] < A[i]) {
        c++;
        t = A[i];
        A[i] = A[i - 1];
        A[i - 1] = t;
      }
  9. Демо 2014 (A12). Ниже приведён фрагмент программы, записанный на четырёх языках программирования.
    Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.
    БейсикПаскаль
    J = 1
    FOR I = 1 TO n
      IF A(I) < A(J) THEN J = I
    NEXT I
    s = J
    j := 1;
    for i := 1 to n do
    begin
      if A[i] < A[j] then
        j := i
      end;
    s := j;
    СиАлгоритмический язык
    j = 1;
    for (i = 1; i <= n; i++) {
      if (A[i] < A[j]) {
        j = i;
      }
    }
    s = j;
    j := 1
    нц для i от 1 до n
      если A[i] < A[j] то
        j := i
      все
    кц
    s := j
    Чему будет равно значение переменной s после выполнения данного фрагмента программы?
    1) минимальному элементу в массиве A
    2) индексу минимального элемента в массиве A (наименьшему из таких индексов, если минимальных элементов несколько)
    3) индексу минимального элемента в массиве A (наибольшему из таких индексов, если минимальных элементов несколько)
    4) количеству элементов, равных минимальному в массиве A
  10. Демо 2013 (A12). В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.
    БейсикПаскаль
    FOR i=0 TO 10
      A(i)=i-1
    NEXT i
    FOR i=1 TO 10
      A(i-1)=A(i)
    NEXT i
    A(10)=10
    for i:=0 to 10 do
      A[i]:=i-1;
    for i:=1 to 10 do
      A[i-1]:=A[i];
    A[10]:=10;
    СиАлгоритмический язык
    for (i=0;i<=10;i++)
      A[i]=i-1;
    for (i=1;i<=10;i++)
      A[i-1]=A[i];
    A[10]=10;
    нц для i от 0 до 10
      A[i]:=i-1
    кц
    нц для i от 1 до 10
      A[i-1]:=A[i]
    кц
    A[10]:=10
    Как изменятся элементы этого массива после выполнения фрагмента программы?
    1) все элементы, кроме последнего, окажутся равны между собой
    2) все элементы окажутся равны своим индексам
    3) все элементы, кроме последнего, будут сдвинуты на один элемент вправо
    4) все элементы, кроме последнего, уменьшатся на единицу
  11. Демо 2012 (A12). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Ниже представлен фрагмент программы, записанный на разных языках программирования, в котором значения элементов сначала задаются, а затем меняются.
    БейсикПаскаль
    FOR i=0 TO 9
      A(i) = 9-i
    NEXT i
    FOR i = 0 TO 4
      k = A(i)
      A(i) = A(9-i)
      A(9-i) = k
    NEXT i
    for i:=0 to 9 do
      A[i] := 9-i;
    for i:=0 to 4 do
    begin
      k := A[i];
      A[i] := A[9-i];
      A[9-i] := k;
    end;
    СиАлгоритмический язык
    for (i=0;i<=9;i++)
      A[i] = 9-i;
    for (i=0;i<=4;i++)
    {
      k = A[i];
      A[i] = A[9-i];
      A[9-i] = k;
    }
    нц для i от 0 до 9
      A[i]:= 9-i
    кц
    нц для i от 0 до 4
      k := A[i]
      A[i] := A[9-i]
      A[9-i] := k
    кц
    Чему будут равны элементы этого массива после выполнения фрагмента программы?
    1) 9 8 7 6 5 4 3 2 1 0
    2) 0 1 2 3 4 5 6 7 8 9
    3) 9 8 7 6 5 5 6 7 8 9
    4) 0 1 2 3 4 4 3 2 1 0
  12. Демо 2011 (A17). В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.
    БейсикПаскаль
    FOR i=0 TO 10
      A(i)=i-1
    NEXT i
    FOR i=10 TO 1 STEP -1
      A(i-1)=A(i)
    NEXT i
    for i:=0 to 10 do
    A[i]:=i-1;
    for i:=10 downto 1 do
      A[i-1]:=A[i];
    СиАлгоритмический язык
    for (i=0;i<=10;i++)
      A[i]=i-1;
    for (i=10;i>=1;i--)
      A[i-1]=A[i];
    нц для i от 0 до 10
      A[i]:=i-1
    кц
    нц для i от 10 до 1 шаг -1
      A[i-1]:=A[i]
    кц
    Чему окажутся равны элементы этого массива?
    1) 9 9 9 9 9 9 9 9 9 9 9
    2) 0 1 2 3 4 5 6 7 8 9 9
    3) 0 1 2 3 4 5 6 7 8 9 10
    4) -1 -1 0 1 2 3 4 5 6 7 8
  13. Демо 2010 (A6). В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент программы, записанный на разных языках программирования, в котором значения элементов сначала задаются, а затем меняются.
    БейсикПаскаль
    FOR i=0 TO 10
      A(i)=i
    NEXT i
    FOR i=0 TO 10
      A(10-i)=A(i)
      A(i)=A(10-i)
    NEXT i
    for i:=0 to 10 do
      A[i]:=i;
    for i:=0 to 10 do
    begin
      A[10-i]:=A[i];
      A[i]:=A[10-i];
    end;
    СиАлгоритмический язык
    for (i=0;i<=10;i++)
      A[i]=i;
    for (i=0;i<=10;i++)
    {
      A[10-i]=A[i];
      A[i]=A[10-i];
    }
    нц для i от 0 до 10
      A[i]:=i
    кц
    нц для i от 0 до 10
      A[10-i]:=A[i]
      A[i]:=A[10-i]
    кц
    Чему будут равны элементы этого массива после выполнения фрагмента программы?
    1) 10 9 8 7 6 5 4 3 2 1 0
    2) 0 1 2 3 4 5 6 7 8 9 10
    3) 10 9 8 7 6 5 6 7 8 9 10
    4) 0 1 2 3 4 5 4 3 2 1 0
  14. Демо 2009 (A6). Дан фрагмент программы, обрабатывающей двухмерный массив A размера n×n.
    БейсикПаскальАлгоритмический язык
    k = 1
    FOR i = 1 TO n
      c = A(i,i)
      A(i,i) = A(k,i)
      A(k,i) = c
    NEXT i
    k:=1;
    for i:=1 to n do
    begin
      c:=A[i,i];
      A[i,i]:=A[k,i];
      A[k,i]:=c
    end
    k:=1
    нц для i от 1 до n
      c:=A[i,i]
      A[i,i]:=A[k,i]
      A[k,i]:=c
    кц
    Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами
    1) два столбца в таблице
    2) две строки в таблице
    3) элементы диагонали и k-ой строки таблицы
    4) элементы диагонали и k-го столбца таблицы
  15. Демо 2008 (A8). Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:
    БейсикПаскальАлгоритмический язык
    FOR n=1 TO 100
      A(n)=(n-80)*(n-80)
    NEXT n
    FOR n=1 TO 100
      B(101-n)=A(n)
    NEXT n
    for n:=1 to 100 do
      A[n]:= (n-80)*(n-80);
    for n:=1 to 100 do
      B[101-n]:=A[n];
    нц для n от 1 до 100
      A[n]=(n-80)*(n-80)
    кц
    нц для n от 1 до 100
      B[101-n]=A[n]
    кц
    Какой элемент массива B будет наибольшим?
    1) B[1] 2) B[21] 3) B[80] 4) B[100]
  16. (т2-2012/1). В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент программы, обрабатывающей данный массив. Для вашего удобства этот фрагмент записан на четырех языках программирования.
    Бейсик
    	s = 0
    	z = A(0)
    	FOR i = 1 TO n
    	    IF A(i) < z THEN s = s + A(i)
    	NEXT i
    
    Чему будет равно значение переменной s после выполнения данной программы? Ответ должен быть верным при любых значениях элементов массива.
    1) Минимальному элементу в массиве A
    2) Количеству элементов массива A, меньших первого элемента массива
    3) Сумме всех элементов массива А, меньших первого элемента массива
    4) Индексу последнего элемента массива А, который меньше A[0]
  17. (т2-2012/2). В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент программы, обрабатывающей данный массив. Для вашего удобства этот фрагмент записан на четырех языках программирования.
    Бейсик
    	s = 0
    	z = A(0)
    	FOR i = 1 TO n
    	    IF A(i) > z THEN s = s + A(i)
    	NEXT i
    
    Чему будет равно значение переменной s после выполнения данной программы? Ответ должен быть верным при любых значениях элементов массива.
    1) Максимальному элементу в массиве A
    2) Количеству элементов массива A, больших первого элемента массива
    3) Сумме всех элементов массива А, больших первого элемента массива
    4) Индексу последнего элемента массива А, который больше A[0]
  18. с114 (17). Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.
    БейсикПаскаль
    s = 0
    n = 10
    FOR i = 2 TO n
      s = s+A(i)*A(i)-A(i-1)*A(i-1)
    NEXT i
    s:=0;
    n:=10;
    for i:= 2 to n do begin
      s:=s+A[i]*A[i]-A[i-1]*A[i-1];
    end;
    СиАлгоритмический язык
    s = 0;
    n = 10;
    for (i = 2; i <= n; i++)
      s=s + A[i]*A[i]-A[i-1]*A[i-1];
    s:=0
    n:=10
    нц для i от 2 до n
      s:=s + A[i]*A[i]-A[i-1]*A[i-1];
    кц
    Python
    s=0
    n=10
    for i in range(2,n+1):
      s=s + A[i]*A[i]-A[i-1]*A[i-1]
    В начале выполнения этого фрагмента в массиве находились числа 1, 11, 22, 33, 44, 55, 66, 77, 88, 99, т.е. A[1]=1, A[2]=11 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?
  19. с124 (17). Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.
    БейсикПаскаль
    s = 0
    n = 10
    FOR i = 2 TO n
      s = s+A(i)*A(i)-A(i-1)*A(i-1)
    NEXT i
    s:=0;
    n:=10;
    for i:= 2 to n do begin
      s:=s+A[i]*A[i]-A[i-1]*A[i-1];
    end;
    СиАлгоритмический язык
    s = 0;
    n = 10;
    for (i = 2; i <= n; i++)
      s=s + A[i]*A[i]-A[i-1]*A[i-1];
    s:=0
    n:=10
    нц для i от 2 до n
      s:=s + A[i]*A[i]-A[i-1]*A[i-1];
    кц
    Python
    s=0
    n=10
    for i in range(2,n+1):
      s=s + A[i]*A[i]-A[i-1]*A[i-1]
    В начале выполнения этого фрагмента в массиве находились числа 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, т.е. A[1]=1, A[2]=12 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?
  20. с113 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i) < A(i-1) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i-1)
        A(i-1) = t
      END IF
    NEXT i
    c = 0
    for i in range(1,10):
      if A[i] < A[i-1]:
        c = c + 1
        t = A[i]
        A[i] = A[i-1]
        A[i-1] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 9
      если A[i] < A[i-1] то
        c := c + 1
        t := A[i]
        A[i] := A[i-1]
        A[i-1] := t
      все
    кц
    c := 0;
    for i := 1 to 9 do begin
      if A[i] < A[i-1] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i-1];
        A[i-1] := t;
      end;
    end;
    Си
    c = 0;
    for (i = 1; i < 10; i++) {
      if (A[i] < A[i-1]) {
        c++;
        t = A[i];
        A[i] = A[i-1];
        A[i-1] = t;
      }
    }
  21. с123 (19). В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 16, 27, 43, 8, 15, 11, 12, 70, 91, 4 соответственно, т.е. A[0] = 16, A[1] = 27 и т.д.
    Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.
    БейсикPython
    c = 0
    FOR i = 1 TO 9
      IF A(i) < A(i-1) THEN
        c = c + 1
        t = A(i)
        A(i) = A(i-1)
        A(i-1) = t
      END IF
    NEXT i
    c = 0
    for i in range(1,10):
      if A[i] < A[i-1]:
        c = c + 1
        t = A[i]
        A[i] = A[i-1]
        A[i-1] = t
    Алгоритмический языкПаскаль
    c := 0
    нц для i от 1 до 9
      если A[i] < A[i-1] то
        c := c + 1
        t := A[i]
        A[i] := A[i-1]
        A[i-1] := t
      все
    кц
    c := 0;
    for i := 1 to 9 do begin
      if A[i] < A[i-1] then
      begin
        c := c + 1;
        t := A[i];
        A[i] := A[i-1];
        A[i-1] := t;
      end;
    end;
    Си
    c = 0;
    for (i = 1; i < 10; i++) {
      if (A[i] < A[i-1]) {
        c++;
        t = A[i];
        A[i] = A[i-1];
        A[i-1] = t;
      }
    }
  22. с112 (19).
  23. с122 (19).
  24. ш115 (19).
  25. ш125 (19).
  26. ш114 (19).
  27. ш124 (19).
  28. ш113 (19).
  29. ш123 (19).
  30. ш112 (19).
  31. ш122 (19).
  32. ш111 (19).
  33. ш121 (19).


Copyright © 1993–2020 Мацкявичюс Д.А. Все права защищены.
Никакая часть сайта не может быть воспроизведена никаким способом без письменного разрешения правообладателя и явной ссылки на данный ресурс.