ЕГЭ, вопрос 8: Б. Определения результата выполнения
простейшей программы (5-10 строк)

Проверяемые элементы содержания по спецификации (2019): Знание основных конструкций языка программирования, понятия переменной, оператора присваивания

Кодификатор 1.7.2/1.1.4. Уровень сложности Б, 1 балл.

Время выполнения – 3 минуты.

Сложность задания невысока, но из года в год понемногу возрастает.

Задания

  1. Демо 2020 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 1
    WHILE S < 51
      S = S + 11
      N = N * 2
    WEND
    PRINT N
    s = 0
    n = 1
    while s < 51:
      s = s + 11
      n = n * 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 0
    n := 1
    нц пока s < 51
      s := s + 11
      n := n * 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 1;
    while s < 51 do
      begin
      s := s + 11;
      n := n * 2
    end;
    writeln(n)
    end.
    C++
    #include <iostream>
    using namespace std;
    int main()
    { int s = 0, n = 1;
      while (s < 51) { s = s + 11; n = n * 2; }
      cout << n << endl;
      return 0;
    }

  2. Демо 2019 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 75
    WHILE S + N < 150
      S = S + 15
      N = N - 5
    WEND
    PRINT N
    s = 0
    n = 75
    while s + n < 150:
      s = s + 15
      n = n - 5
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 0
    n := 75
    нц пока s + n < 150
      s := s + 15
      n := n - 5
    кц
    вывод n
    кон
    var s, n: integer;
    begin
      s := 0;
      n := 75;
      while s + n < 150 do
      begin
        s := s + 15;
        n := n - 5
    end.
    writeln(n) end;
    Си++
    #include <iostream>
    using namespace std;
    int main() {
    int s = 0, n = 75;
    while (s + n < 150) {
      s = s + 15;
      n = n - 5;
    }
    cout << n << endl;
    return 0;
    }

  3. Демо 2018 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 260
    N = 0
    WHILE S > 0
      S = S - 15
      N = N + 2
    WEND
    PRINT N
    s = 260
    n = 0
    while s > 0:
      s = s - 15
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 260
    n := 0
    нц пока s > 0
      s := s - 15
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
      s := 260;
      n := 0;
      while s > 0 do
      begin
        s := s - 15;
        n := n + 2
      end;
    writeln(n)
    end.
    Си++
    #include <iostream>
    using namespace std;
    int main() {
    int s = 260, n = 0;
    while (s > 0) {
      s = s - 15;
      n = n + 2;
    }
    cout << n << endl;
    return 0;
    }

  4. D2018 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 150
    N = 0
    WHILE S + N < 300
      S = S - 5
      N = N + 25
    WEND
    PRINT N
    s = 150
    n = 0
    while s + n < 300:
      s = s - 5
      n = n + 25
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 150
    n := 0
    нц пока s + n < 300
      s := s - 5
      n := n + 25
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 150;
    n := 0;
    while s + n < 300 do
    begin
      s := s - 5;
      n := n + 25
    end;
    writeln(n)
    end.
    C++
    #include <iostream>
    using namespace std;
    int main() {
    int s = 150, n = 0;
    while (s + n < 300) {
      s = s - 5;
      n = n + 25;
    }
    cout << n << endl;
    return 0;
    }

  5. Демо 2017 (8). Определите, какое число будет напечатано в результате выполнения программы, записанной ниже на пяти языках программирования.
    БейсикPython
    DIM N, S AS INTEGER
    N = 1
    S = 0
    WHILE N <= 150
      S = S + 30
      N = N * 5
    WEND
    PRINT S
    n = 1
    s = 0
    while n <= 150:
      s = s + 30
      n = n * 5
    print(s)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 1
    s := 0
    нц пока n <= 150
      s := s + 30
      n := n * 5
    кц
    вывод s
    кон
    var n, s: integer;
    begin
    n := 1;
    s := 0;
    while n <= 150 do
      begin
      s := s + 30;
      n := n * 5
    end;
    write(s)
    end.
    Си
    #include<stdio.h>
    int main()
    {
    int n, s;
    n = 1;
    s = 0;
    while (n <= 150)
    {
      s = s + 30;
      n = n * 5;
    }
    printf("%d", s);
    return 0;
    }

  6. Демо 2016 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S < 111
      S = S + 8
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while s < 111:
      s = s + 8
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока s < 111
      s := s + 8
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s < 111 do
    begin
      s := s + 8;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main()
    { int s = 0, n = 0;
      while (s < 111) { s = s + 8; n = n + 2; }
      printf("%d\n", n);
      return 0;
    }

  7. Демо 2015 (8). Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 33
    N = 1
    WHILE S > 0
      S = S – 7
      N = N * 3
    WEND
    PRINT(N)
    s = 33
    n = 1
    while s > 0:
      s = s - 7
      n = n * 3
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    s := 33
    n := 1
    нц пока s > 0
      s := s — 7
      n := n * 3
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 33;
    n := 1;
    while s > 0 do
    begin
      s := s – 7;
      n := n * 3
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main(void)
    { int s, n;
    s = 33;
    n = 1;
    while (s > 0) {
      s = s – 7;
      n = n * 3;
    }
    printf("%d\n", n);
    }

  8. Демо 2014 (B2). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.
    БейсикПаскаль
    a = 25
    b = 12
    a = 3 * b - a
    IF a > b THEN
      c = 2 * a - b
    ELSE
      c = 2 * a + b
    ENDIF
    a := 25;
    b := 12;
    a := 3 * b - a;
    if a > b then
      c := 2 * a - b
    else
      c := 2 * a + b;
    СиАлгоритмический язык
    a = 25;
    b = 12;
    a = 3 * b - a;
    if (a > b)
      c = 2 * a - b;
    else
      c = 2 * a + b;
    a := 25
    b := 12
    a := 3 * b - a
    если a > b
      то c := 2 * a - b
      иначе c := 2 * a + b
    все

  9. Демо 2014 (B5). Запишите число, которое будет напечатано в результате выполнения программы (для Вашего удобства программа представлена на четырёх языках программирования).
    БейсикПаскаль
    DIM N, S AS INTEGER
    N = 0
    S = 0
    WHILE S <= 325
      S = S + 10
      N = N + 3
    WEND
    PRINT N
    var n, s: integer;
    begin
    n := 0;
    s := 0;
    while s <= 325 do
    begin
      s := s + 10;
      n := n + 3
    end;
    write(n)
    end.
    СиАлгоритмический язык
    #include<stdio.h>
    void main()
    {
    int n, s;
    n = 0;
    s = 0;
    while (s <= 325)
    {
      s = s + 10;
      n = n + 3;
    }
    printf("%d", n);
    }
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока s <= 325
      s := s + 10
      n := n + 3
    кц
    вывод n
    кон

  10. Демо 2013 (B2). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.
    БейсикПаскаль
    a = 30
    b = 14
    a = a – 2 * b
    IF a > b THEN
      c = b + 2 * a
    ELSE
      c = b - 2 * a
    ENDIF
    a := 30;
    b := 14;
    a := a – 2 * b;
    if a > b then
      c := b + 2 * a
    else
      c := b - 2 * a;
    СиАлгоритмический язык
    a = 30;
    b = 14;
    a = a – 2 * b;
    if (a > b)
      c = b + 2 * a;
    else
      c = b - 2 * a;
    a := 30
    b := 14
    a := a – 2 * b
    если a > b
      то c := b + 2 * a
      иначе c := b - 2 * a
    все

  11. Демо 2012 (B3). Определите, что будет напечатано в результате работы следующего фрагмента программы:
    БейсикПаскаль
    DIM k, s AS INTEGER
    s = 0
    k = 0
    WHILE s < 1024
      s = s + 10
      k = k + 1
    WEND
    PRINT k
    Var k, s : integer;
    BEGIN
    s := 0;
    k := 0;
    while s<1024 do
    begin
      s := s+10;
      k := k+1;
    end;
    write(k);
    END.
    СиАлгоритмический язык
    {
    int k, s;
    s = 0;
    k = 0;
    while (s<1024) {
      s = s+10;
      k = k+1;
    }
    printf("%d", k);
    }
    нач
    цел k, s
    s := 0
    k := 0
    нц пока s < 1024
      s := s+10
      k := k+1
    кц
    вывод k
    кон

  12. Демо 2012 (B6). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования).
    БейсикПаскаль
    a = 40
    b = 80
    b = - a - 2 * b
    IF a < b THEN
      c = b - a
    ELSE
      c = a - 2 * b
    END IF
    a := 40;
    b := 80;
    b := - a - 2 * b;
    if a < b then
      c := b - a
    else
      c := a - 2 * b;
    СиАлгоритмический язык
    a = 40;
    b = 80;
    b = - a - 2 * b;
    if (a < b)
      c = b – a;
    else
      c = a - 2 * b;
    a := 40
    b := 80
    b := - a - 2 * b
    если a < b
      то c := b - a
      иначе c := a - 2 * b
    все

  13. Демо K-2012 (A10). В приведённом ниже фрагменте алгоритма, записанном на некотором языке программирования, переменные a, b, c — строкового типа, а переменные i, k — целого. Используются следующие функции.
    Len (a) — возвращает количество символов в строке a. (Тип «целое»)
    Get (a, i) — возвращает i-й (слева) символ в строке a. (Тип «строка»)
    Concat (a, b) — возвращает строку, в которой записаны сначала все символы строки a, а затем все символы строки b. (Тип «строка»)
    Значения строк записываются в одинарных кавычках (например, a := ‘кот’).
    Конструкция While условие{операторы} означает цикл с предусловием, в котором выполняются операторы, пока истинно условие.
    Фрагмент алгоритма:
    i := Len (a)
    k := 2
    b := ‘T’
    While i > 0
    {
      c := Get (a, i)
      b := Concat (b, c)
      i := i − k
    }
    b := Concat (‘Р’,b)
    Какое значение будет у переменной b после выполнения вышеприведённого фрагмента алгоритма, если значение переменной a было ‘КАТЕР’?
    1) ‘РТРТК’ 2) ‘РЕТАК’ 3) ‘РТТТК’ 4) ‘РАТЕК’
  14. Демо 2011 (A8). Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и с – переменные вещественного (действительного) типа.
    БейсикПаскаль
    a = 120
    b = 100
    a = a + b / 2
    IF b < a / 2 THEN
      c = b + a
    ELSE
      c = b + a / 2
    ENDIF
    a := 120;
    b := 100;
    a := a + b / 2;
    if b < a / 2
    then
      c := b + a
    else
      c := b + a / 2;
    СиАлгоритмический язык
    b = 100;
    a = a + b / 2;
    if (b < a / 2)
      c = b + a;
    else
      c = b + a / 2;
    a := 120
    b := 100
    a := a + b / 2
    если b < a / 2
      то c := b + a
      иначе c := b + a / 2
    все
    1) c = 105 2) c = 160 3) c = 185 4) c = 270
  15. Демо 2010 (A5). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования):
    БейсикПаскаль
    a = 100
    b = 30
    a = a – b * 3
    IF a > b THEN
      c = a – b
    ELSE c = b – a
    ENDIF
    a := 100;
    b := 30;
    a := a – b * 3;
    if a > b then
      c := a – b
    else c := b – a;
    СиАлгоритмический язык
    a = 100;
    b = 30;
    a = a – b * 3;
    if (a > b)
      c = a – b;
    else c = b – a;
    a := 100
    b := 30
    a := a – b * 3
    если a > b то c := a – b
      иначе c := b – a
    все
    1) c = 20 2) c = 70 3) c = –20 4) c = 180
  16. Демо 2009 (A5). Определите значение переменной c после выполнения следующего фрагмента программы.
    БейсикПаскальАлгоритмический язык
    a = 5
    a = a + 6
    b = – a
    c = a – 2 * b
    a:=5;
    a:=a+6;
    b:= –a;
    c:=a–2*b;
    a:=5
    a:=a+6
    b:= –a
    c:=a–2*b
    1) c = –11 2) c = 15 3) c = 27 4) c = 33
  17. Демо 2008 (A7). Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
    БейсикПаскальАлгоритмический язык
    a = 3 + 8 * 4
    b = (a \ 10) + 14
    a = (b MOD 10) + 2
    '\ и MOD – операции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно
    a:= 3 + 8*4;
    b:= (a div 10) + 14;
    a:= (b mod 10) + 2;
    {div и mod – операции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно}
    a:= 3 + 8*4
    b:= div(a,10) + 14
    a:= mod(b, 10) + 2
    |div и mod – функции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно|
    1) a = 0, b = 18
    2) a = 11, b = 19
    3) a = 10, b = 18
    4) a = 9, b = 17

  18. (т2-2012/1). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования):
    	a = 30
    	b = 10
    	a = a / b * 2
    	IF a > b THEN
    		c = a - 4 * b
    	ELSE
    		c = a + 4 * b
    	ENDIF
    

  19. (т2-2012/2). Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования):
    	a = 40
    	b = 10
    	a = a / b * 2
    	IF a > b THEN
    		c = a - 4 * b
    	ELSE
    		c = a + 4 * b
    	ENDIF
    
  20. с114 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 20
    N = 0
    WHILE 91 < S*S
      S = S - 1
      N = N + 2
    WEND
    PRINT N
    s = 20
    n = 0
    while 91 < s*s:
      s = s - 1
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    s := 20
    n := 0
    нц пока 91 < s*s
      s := s - 1
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 20;
    n := 0;
    while 91 < s*s do
    begin
      s := s - 1;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main()
    {
    int s = 20, n = 0;
    while (91 < s*s) {
      s = s - 1;
      n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }
  21. с124 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 20
    N = 0
    WHILE 91 < S*S
      S = S - 1
      N = N + 3br> WEND
    PRINT N
    s = 20
    n = 0
    while 91 < s*s:
      s = s - 1
      n = n + 3
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    s := 20
    n := 0
    нц пока 91 < s*s
      s := s - 1
      n := n + 3
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 20;
    n := 0;
    while 91 < s*s do
    begin
      s := s - 1;
      n := n + 3
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main()
    {
    int s = 20, n = 0;
    while (91 < s*s) {
      s = s - 1;
      n = n + 3;
    }
    printf("%d\n", n);
    return 0;
    }
  22. R2018 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 170
    WHILE S + N < 325
      S = S + 25
      N = N - 5
    WEND
    PRINT S
    s = 0 n = 170
    while s + n < 325:
      s = s + 25
      n = n - 5
    print(s)
    Си++Паскаль
    #include <iostream>
    using namespace std;
    int main() {
    int s = 0, n = 170;
    while (s + n < 325) {
      s = s + 25;
      n = n - 5;
    }
    cout << s << endl;
    return 0;
    }
    var s, n: integer;
    begin
    s := 0;
    n := 170;
    while s + n < 325 do
    begin
      s := s + 25;
      n := n - 5
    end;
    writeln(s)
    end.

  23. с113 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 20
    N = 0
    WHILE 111 < S*S
      S = S - 1
      N = N + 1
    WEND
    PRINT N
    s = 20
    n = 0
    while 111 < s*s:
      s = s - 1
      n = n + 1
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    n := 0
    s := 20
    нц пока 111 < s*s
      s := s - 1
      n := n + 1
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 20;
    n := 0;
    while 111 < s*s do
    begin
      s := s - 1;
      n := n + 1
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 20, n = 0;
    while (111 < s*s) {
      s = s - 1;
      n = n + 1;
    }
    printf("%d\n", n);
    return 0;
    }

  24. с123 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 20
    N = 0
    WHILE 70 < S*S
      S = S - 1
      N = N + 1
    WEND
    PRINT N
    s = 20
    n = 0
    while 70 < s*s:
      s = s - 1
      n = n + 1
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    n := 0
    s := 20
    нц пока 70 < s*s
      s := s - 1
      n := n + 1
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 20;
    n := 0;
    while 70 < s*s do
    begin
      s := s - 1;
      n := n + 1
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 20, n = 0;
    while (70 < s*s) {
      s = s - 1;
      n = n + 1;
    }
    printf("%d\n", n);
    return 0;
    }

  25. с112 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S*S < 101
      S = S + 1
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while s*s < 101:
      s = s + 1
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    n := 0
    s := 0
    нц пока s*s < 101
      s := s + 1
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s*s < 101 do
    begin
      s := s + 1;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s*s < 101) {
      s = s + 1;
      n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }

  26. с122 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S*S < 99
      S = S + 1
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while s*s < 99:
      s = s + 1
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    n := 0
    s := 0
    нц пока s*s < 99
      s := s + 1
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s*s < 99 do
    begin
      s := s + 1;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s*s < 99) {
      s = s + 1;
      n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }

  27. ш115 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE 2*S*S <= 10*S
      S = S + 1
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while 2*s*s <= 10*s:
      s = s + 1
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока 2*s*s <= 10*s
      s := s + 1
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while 2*s*s <= 10*s do
    begin
      s := s + 1;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (2*s*s <= 10*s) {
      s = s + 1;
      n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }

  28. ш125 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE 2*S*S <= 10*S
      S = S + 1
      N = N + 3
    WEND
    PRINT N
    s = 0
    n = 0
    while 2*s*s <= 10*s:
      s = s + 1
      n = n + 3
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока 2*s*s <= 10*s
      s := s + 1
      n := n + 3
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while 2*s*s <= 10*s do
    begin
      s := s + 1;
      n := n + 3
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (2*s*s <= 10*s) {
      s = s + 1;
      n = n + 3;
    }
    printf("%d\n", n);
    return 0;
    }

  29. ш114 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 1
    WHILE S < 150
      S = S + 15
      N = N * 2
    WEND
    PRINT N
    s = 0
    n = 1
    while s < 150:
      s = s + 15
      n = n * 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    s := 0
    n := 1
    нц пока s < 150
      s := s + 15
      n := n * 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 1;
    while s < 150 do
    begin
      s := s + 15;
      n := n * 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0;
    int n = 1;
    while (s < 150) {
      s = s + 15;
      n = n * 2;
    }
    printf("%d\n", n);
    return 0;
    }

  30. ш124 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 1
    WHILE S < 165
      S = S + 15
      N = N * 2
    WEND
    PRINT N
    s = 0
    n = 1
    while s < 165:
      s = s + 15
      n = n * 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел s, n
    s := 0
    n := 1
    нц пока s < 165
      s := s + 15
      n := n * 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 1;
    while s < 165 do
    begin
      s := s + 15;
      n := n * 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0;
    int n = 1;
    while (s < 165) {
      s = s + 15;
      n = n * 2;
    }
    printf("%d\n", n);
    return 0;
    }

  31. ш113 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S < 165
      S = S + 15
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while s < 165:
      s = s + 15
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока s < 165
      s := s + 15
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s < 165 do
    begin
      s := s + 15;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s < 165) {
      s = s + 15;
      n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }

  32. ш123 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S < 165
      S = S + 15
      N = N + 5
    WEND
    PRINT N
    s = 0
    n = 0
    while s < 165:
      s = s + 15
      n = n + 5
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    n := 0
    s := 0
    нц пока s < 165
      s := s + 15
      n := n + 5
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s < 165 do
    begin
      s := s + 15;
      n := n + 5
    end;
    writeln(n)
    end.
    Си
    #include <stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s < 165) {
      s = s + 15;
      n = n + 5;
    }
    printf("%d\n", n);
    return 0;
    }

  33. ш112 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S < 123
      S = S + 12
      N = N + 2
    WEND
    PRINT N
    s = 0
    n = 0
    while s < 123:
      s = s + 12
      n = n + 2
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 0
    n := 0
    нц пока s < 123
      s := s + 12
      n := n + 2
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s < 123 do
    begin
      s := s + 12;
      n := n + 2
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s < 123) {
      s = s + 12;   n = n + 2;
    }
    printf("%d\n", n);
    return 0;
    }

  34. ш122 (8). Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.
    БейсикPython
    DIM S, N AS INTEGER
    S = 0
    N = 0
    WHILE S < 123
      S = S + 12
      N = N + 3
    WEND
    PRINT N
    s = 0
    n = 0
    while s < 123:
      s = s + 12
      n = n + 3
    print(n)
    Алгоритмический языкПаскаль
    алг
    нач
    цел n, s
    s := 0
    n := 0
    нц пока s < 123
      s := s + 12
      n := n + 3
    кц
    вывод n
    кон
    var s, n: integer;
    begin
    s := 0;
    n := 0;
    while s < 123 do
    begin
      s := s + 12;
      n := n + 3
    end;
    writeln(n)
    end.
    Си
    #include<stdio.h>
    int main()
    {
    int s = 0, n = 0;
    while (s < 123) {
      s = s + 12;   n = n + 3;
    }
    printf("%d\n", n);
    return 0;
    }

  35. ш111 (8).
  36. ш121 (8).


Copyright © 1993–2020 Мацкявичюс Д.А. Все права защищены.
Никакая часть сайта не может быть воспроизведена никаким способом без письменного разрешения правообладателя и явной ссылки на данный ресурс.