Вопрос 10 ОГЭ (ГИА-9): Умение исполнить циклический алгоритм обработки массива чисел, записанный на алгоритмическом языке

Проверяемый предметный результат обучения по спецификации (2020): .

Кодификатор 1.3.1/1.3.2/2.3. Уровень сложности П, 1 балл.

Время выполнения – 6 минуты.

Теоретический материал.

Задания

  1. Демо 2020 ().
  2. Демо 2020 [проект] (10). В результате выполнения программы напечатано число 10. Какое наибольшее значение может иметь переменная S после выполнения программы? Текст программы приведён на трёх языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    целтаб Dat[1:100]
    цел k, m, S, N
    N := 5
    нц для k от 1 до N
      ввод Dat[k]
    кц
    m := 0; S := 0
    нц для k от 1 до N
      S:= S + Dat[k]
      если Dat[k]>m то
        m := Dat[k]
      все
    кц
    вывод m
    кон
    DIM Dat(100) AS INTEGER
    DIM N AS INTEGER
    DIM k, m, S AS INTEGER
    N = 5
    FOR k = 1 TO N
      INPUT Dat(k)
    NEXT k
    m = 0
    S = 0
    FOR k = 1 TO N
      S = S + Dat(k)
      IF Dat(k)>m THEN
        m = Dat(k)
      END IF
    NEXT k
    PRINT m
    Var k, m, S, N: integer;
    Dat: array[1..100] of integer;
    Begin
    N:= 5;
    m := 0; S := 0;
    for k := 1 to N do
      readln(Dat[k]);
    for k := 1 to N do begin
      S := S + Dat[k];
      if Dat[k]>m then
      begin
        m := Dat[k]
      end
    end;
    writeln(m)
    End.

  3. Демо 2014-2019 (10). В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя; Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    целтаб Dat[1:10]
    цел k, m
    Dat[1] := 16
    Dat[2] := 20
    Dat[3] := 20
    Dat[4] := 41
    Dat[5] := 14
    Dat[6] := 21
    Dat[7] := 28
    Dat[8] := 12
    Dat[9] := 15
    Dat[10] := 35
    m := 0
    нц для k от 1 до 10
      если Dat[k ]> m то
        m := Dat[k]
      все
    кц
    вывод m
    кон
    DIM Dat(10) AS INTEGER
    DIM k,m AS INTEGER
    Dat(1) = 16: Dat(2) = 20
    Dat(3) = 20: Dat(4) = 41
    Dat(5) = 14: Dat(6) = 21
    Dat(7) = 28: Dat(8) = 12
    Dat(9) = 15:Dat(10) = 35
    m = 0
    FOR k = 1 TO 10
      IF Dat(k) > m THEN
        m = Dat(k)
      ENDIF
    NEXT k
    PRINT m
    Var k, m: integer;
    Dat: array[1..10] of integer;
    Begin
    Dat[1] := 16; Dat[2] := 20;
    Dat[3] := 20; Dat[4] := 41;
    Dat[5] := 14; Dat[6] := 21;
    Dat[7] := 28; Dat[8] := 12;
    Dat[9] := 15; Dat[10] := 35;
    m := 0;
    for k := 1 to 10 do
      if Dat[k] > m then
      begin
        m := Dat[k]
      end;
    writeln(m);
    End.
    PythonСи++
    Dat = [16, 20, 20, 41, 14, 21, 28,
    12, 15, 35]
    m = 0
    for k in range (0,10) :
      if Dat[k] > m :
        m = Dat [k]
    print (m)
    #include <iostream>
    using namespace std;
    int main() {
    int Dat[10] = { 16, 20, 20, 41, 14, 21, 28, 12, 15, 35};
    int m= 0;
    for (int k =0; k<10; k++)
      if (Dat[k] > m) m = Dat [k];
    cout << m;
    return 0;
    }

  4. Демо 2013 (10). В таблице Dat хранятся данные о численности учеников в классах (Dat[1] – число учеников в первом классе, Dat[2] – во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    целтаб Dat[1:11]
    цел k, m
    Dat[1] := 20; Dat[2] := 25
    Dat[3] := 19; Dat[4] := 25
    Dat[5] := 26; Dat[6] := 22
    Dat[7] := 24; Dat[8] := 28
    Dat[9] := 26; Dat[10] := 21
    Dat[11] := 27
    m := 0
    нц для k от 1 до 11
      если Dat[k] > 22 то
        m := m + 1
      все
    кц
    вывод m
    кон
    DIM Dat(11) AS INTEGER
    DIM k,m AS INTEGER
    Dat(1) = 20: Dat(2) = 25
    Dat(3) = 19: Dat(4) = 25
    Dat(5) = 26: Dat(6) = 22
    Dat(7) = 24: Dat(8) = 28
    Dat(9) = 26: Dat(10) = 21
    Dat(11) = 27
    m = 0
    FOR k = 1 TO 11
      IF Dat(k) > 22 THEN
        m = m + 1
      END IF
    NEXT k
    PRINT m
    Var k, m: integer;
    Dat: array[1..11] of integer;
    Begin
    Dat[1] := 20; Dat[2] := 25;
    Dat[3] := 19; Dat[4] := 25;
    Dat[5] := 26; Dat[6] := 22;
    Dat[7] := 24; Dat[8] := 28;
    Dat[9] := 26; Dat[10] := 21;
    Dat[11] := 27;
    m := 0;
    for k := 1 to 11 do
      if Dat[k] > 22 then
      begin
        m := m + 1
    end;
    writeln(m)
    End.

  5. Демо 2012 (10). В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трех алгоритмических языках.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    целтаб Dat[1:7]
    цел k, m, day
    Dat[1]:=7; Dat[2]:=9
    Dat[3]:=10; Dat[4]:=8
    Dat[5]:=6; Dat[6]:=7
    Dat[7]:=6
    day:= 1; m:=Dat[1]
    нц для k от 2 до 7
      если Dat[k] < m то
        m:=Dat[k]; day:=k
      все
    кц
    вывод day
    кон
    DIM Dat(7) AS INTEGER
    Dat(1)=7: Dat(2)=9
    Dat(3)=10: Dat(4)=8
    Dat(5)=6: Dat(6)=7
    Dat(7)=6
    day = 1: m=Dat(1)
    FOR k = 2 TO 7
      IF Dat(k) < m THEN
        m=Dat(k)
        day=k
    END IF
    NEXT k
    PRINT day
    END
    Var k, m, day: integer;
    Dat: array[1..7] of integer;
    Begin
    Dat[1]:=7; Dat[2]:=9;
    Dat[3]:=10; Dat[4]:=8;
    Dat[5]:=6; Dat[6]:=7;
    Dat[7]:=6;
    day:= 1; m:=Dat[1];
    for k:=2 to 7 do begin
      if Dat[k] < m then begin
        m:=Dat[k]; day:=k
      end
    end
    write(day);
    End.

  6. Демо 2011 (11). Определите значение переменной c после выполнения фрагмента алгоритма, записанного в виде блок-схемы:

    Примечание: знаком «:=» обозначена операция присваивания.
    В ответе укажите одно число – значение переменной с.
  7. Демо 2010 (11). Определите значение переменной с после выполнения фрагмента алгоритма, записанного в виде блок-схемы:

    Примечание: знаком «:=» обозначена операция присваивания.
    В ответе укажите одно число – значение переменной с.
  8. Демо 2009 (11). Определите значение переменной с после выполнения фрагмента алгоритма, записанного в виде блок-схемы:

    Примечание: знаком «:=» обозначена операция присваивания.
    В ответе укажите одно число – значение переменной с.


Copyright © 1993–2020 Мацкявичюс Д.А. Все права защищены.
Никакая часть сайта не может быть воспроизведена никаким способом без письменного разрешения правообладателя и явной ссылки на данный ресурс.