Вопрос 9 ОГЭ (ГИА-9): Умение исполнить простейший циклический алгоритм, записанный на алгоритмическом языке

Кодификатор 1.3.1/2.3. Уровень сложности Б, 1 балл.

Время выполнения – 4 минуты.

Теоретический материал.

Задания

  1. Демо 2020 ().
  2. Демо 2020 [проект]. Отсутствует
  3. Демо 2014-2019 (9). Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    цел s, k
    s := 0
    нц для k от 6 до 12
      s := s+10
    кц
    вывод s
    кон
    DIM k, s AS INTEGER
    s = 0
    FOR k = 6 TO 12
      s = s+10
    NEXT k
    PRINT s
    Var s,k: integer;
    Begin
    s := 0;
    for k := 6 to 12 do
      s := s+10;
    writeln(s);
    End.
    Си++Python
    #include <iostream> using namespace std;
    int main() {
    int s = 0;
    for (int k =6; k<13; k++)
      s = s + 10;
    cout << s;
    return 0;
    }
    s = 0
    for k in range (6,13):
      s= s+10
    print (s)

  4. Демо 2013 (9). Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    цел s, k
    s := 8
    нц для k от 3 до 8
      s := s + 8
    кц
    вывод s
    кон
    DIM k, s AS INTEGER
    s = 8
    FOR k = 3 TO 8
      s = s + 8
    NEXT k
    PRINT s
    Var s,k: integer;
    Begin
    s := 8;
    for k := 3 to 8 do
      s := s + 8;
    writeln(s);
    End.

  5. Демо 2012 (9). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.
    Алгоритмический языкБейсикПаскаль
    алг
    нач
    цел s, k
    s:=0,
    нц для k от 1 до 11
      s:=s+12
    кц
    вывод s
    кон
    s = 0
    FOR k = 1 TO 11
      s= s+12
    NEXT k
    PRINT s
    END
    Var s,k: integer;
    Begin
    s:=0;
    for k:=1 to 11 do
      s:=s+12;
    write(s);
    End.

  6. Демо 2010 ().
  7. Демо 2009 (11).


Copyright © 1993–2020 Мацкявичюс Д.А. Все права защищены.
Никакая часть сайта не может быть воспроизведена никаким способом без письменного разрешения правообладателя и явной ссылки на данный ресурс.